Fetch() calls are usually written in the middle of a boilerplate block of code. The first .then() is usually the thing you actually want to do with the data you get back from the database. The code is not DRY, but it's a lot more readable if it's written in a reusable way.
Sort: